CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Does CrossOver work with Mint 20?

I am running Mint 19.3 considering upgrading to 20.0. Does anyone have any experience with CrossOver on MInt 20? Any issues?

Thanks

I did a clean install of Mint 20 (XFCE) this past week have not had any problems. I ran "sudo dpkg --add-architecture i386; sudo apt-get update" ; "reinstalled Crossover using the latest DEB, and just moved my older Crossover bottles from a backup into the new .cxoffice folder (to save reinstalling everything) and everything seems to work fine so far. I've run all the programs at least briefly, but have not had time to test them more fully otherwise.

YES - - it does indeed.
you should Install the 1386 architecture, as an matter of course.

like any 'upgrade' ... there are things that will break,
and whether that is with CX itself, or with the LM20x series.

ie: some of my programs .. did break .. most were able to be re-installed, again.
😀

Can confirm, Linux Mint 20.04 and latest CrossOver working perfectly for Office 2016.

My experience was based on a fresh install of Mint 20. I wasn't able to install Crossover initially, due to missing dependencies reported in the DEB installer. Maybe there are still some components on the way for Mint 20? Eventually I was able to get by by adding the architecture and then updating. (based on random web searches):

https://www.unixmen.com/enable-32-bit-support-64-bit-ubuntu-13-10-greater/

That took a while, as the "dist-upgrade" process updated much of the OS files. I rebooted, then was able to install Crossover. I then imported some bottles as used on Mint 19.3...

Some of the more simple programs worked: Excel-2003, Word-2003.

Then more complex programs either crashed or didn't start at all: Adobe-Photohop-CS, "unable to start because of a hardware or a system error. Sorry but this error is unrecoverable"

So something somewhere needs some work yet.

I don't see why it wouldn't work mint is made off Ubuntu.

If you are replying to me, I don't know either. Since Mint is so easy to load, I could do a fresh reload and see. Also I could re-download the image from linuxmint.com. Perhaps it has been updated in the last few weeks or so?

One little difference between Mint 19.3 and 20 is that another native Linux application I use is looking for the "python" package on Mint 20, which it can't find. I did install that, which installed a metapackage. This is from my notes:

# this is for the latest non-distro version of youtube-dl and perhaps some other apps that look for older code.  It installs "python-is-python2" transitional package on Mint 20:
sudo apt install python  

So in lieu of some changes I have already made, a fresh Mint 20 install is a practical test for me.

Another program in a bottle that wouldn't start for me was a far more complex one that I was lucky to get to work in this environment, and it has been more stable than on Windows XP, which it was designed for. I looked in the Crossover Task Manager and it was starting "explorer.exe" instead (completely unrelated and unnecessary) and then closing that. Not even trying to start the correct program. I don't see the reason for that, if only because the code base of the underlying Linux operating system is the only thing that is changing here. Same version of Crossover on both Mint 19.3 and 20, and same bottle. I even tested that same bottle in the Mint 19.3 environment by restoring it and testing that restored version, which worked as expected.

Okay, just following up from the last post.

To get Crossover working on Mint 20, I just needed to do a

sudo apt update
sudo apt upgrade

after I did the initial fresh OS install.

To get my complex program working, I just needed to open up my install notes from the Mint 18 days. (it helps to refer to one's previous notes)
This one I don't quite understand but it caused it to work back then, probably made it work in Mint 19, and makes it work in Mint 20 (fresh install).
sudo apt update; sudo apt install libgsm1:i386 libldap-2.4-2:i386 libosmesa6:i386
It is extra stuff on the Linux side, which Crossover apparently needs to run a 32 bit Windows program, but doesn't get installed along with Crossover, nor automatically.
https://www.codeweavers.com/support/wiki/linux/faq/Mint

@Bert
I did not upgrade from latest Mint 19.3 to Mint 20 (64-Bit Cinnamon) but made a fresh install and afterwards installed Crossover 19.2 without problems.
All Windows programs I am using are working fine so far. Especially programs using HID devices are working fine.

Did not test latest Crossover beta so far, but I want to do it this week.

Dear all,

Unbelievable. I just saw this :
https://www.youtube.com/watch?v=2LhR_0gQjhk
While I'm no good at all with computers, I did suceed to install the free version of Wondershare Filmora, with a free try of Crossover, on linux 20.
Wondershare Filmora looks to me far better than ... I won't tell the names!

The Free Wondershare filmora works rubbish though.

there does seem to be an issue, when running CX20 on LM20,
and where the inbuilt 'update' method .. will Fail . .

it's still best, to Manually Update, as normal,
but use the 'update notifier' to let you know, that an 'update' is available.

  • no more, manual checking, is needed.
    😎

1 to 12 of 12

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoieW5mU0pBZ1JGNjZxdjZWZSIsImdkcHIiOjB9